Search - SP Page Builder
Easy Profile - Search plugin
جستجو -مجموعه ها
جستجو - تماس ها
جستجو - محتوا
جستجو - خبرخوان ها
جستجو - وب لینک ها
جستجو - برچسب ها
cisco

ایمن سازی روتر سیسکو

امتیاز کاربران

ستاره فعالستاره غیر فعالستاره غیر فعالستاره غیر فعالستاره غیر فعال
 

ایمن سازی روتر سیسکو برای این که خود روتر ها می توانند هدف خوبی برای انواع حملات باشد به شکلی که اگر کسی مثلا مسیریاب مرزی شما رو High Load کند عبور ترافیک به مشکل بر خورده و شبکه شما در ارتباط با اینترنت فلج میشود لذا چند نکته که استفاده از آنها ما را به حداقل امنیت میرساند را باید رعایت کنیم.

 

۱ – پورت های خطرناک را ببندید: یکی از مهم ترین نکات امنیتی میگه که اگر از چیزی استفاده نمی کنید آن را غیرفعال کنید:

 
 
۱۳۰ deny tcp any any range 135 140 (497235 matches)
۱۴۰ deny udp any any range 135 140 (8303931 matches)
۱۵۰ deny tcp any any eq 445 (24650346 matches)
۱۶۰ deny tcp any any eq 449 (11 matches)
۱۷۰ deny tcp any any eq daytime (39 matches)
۱۸۰ deny tcp any any range 27000 27020 (6547 matches)
۱۹۰ deny udp any any range 27000 27020 (290 matches)
۲۰۰ deny tcp any any range 1024 1030 (24568 matches)
۲۱۰ deny tcp any any range 1363 1380 (174634 matches)
۲۲۰ deny udp any any eq 11751 (23 matches)
۲۳۰ deny tcp any any eq 11751 (441 matches)
۲۴۰ deny udp any any eq 1434 (10814 matches)
۲۵۰ deny tcp any any eq 1433 (536911 matches)
۲۶۰ deny udp any any eq 1433 (193 matches)
۲۷۰ deny tcp any any eq 1434 (9133 matches)
۲۸۰ deny tcp any any eq 554 (191 matches)
۲۹۰ deny tcp any any eq 7070 (225 matches)
۳۰۰ deny tcp any any eq 2773 (5923 matches)
۳۱۰ deny tcp any any eq 54283 (590 matches)
۳۲۰ deny udp any any eq echo (812 matches)
۳۳۰ deny tcp any any eq echo (44 matches)
۳۴۰ deny tcp any any eq discard (44 matches)
۳۵۰ deny udp any any eq 554 (204 matches)
۳۶۰ deny udp any any eq 7070 (8 matches)
۳۷۰ deny tcp any any eq 8866 (261 matches)
۳۸۰ deny tcp any any eq 9898 (230 matches)
۳۹۰ deny tcp any any eq 10000 (271 matches)
۴۰۰ deny tcp any any eq 10080 (1031 matches)
۴۱۰ deny tcp any any eq 12345 (432 matches)
۴۲۰ deny tcp any any eq 17300 (221 matches)
۴۳۰ deny tcp any any eq 8554 (255 matches)
۴۴۰ deny udp any any eq 8554 (8 matches)
۴۵۰ deny udp any any eq 4444 (90 matches)
۴۶۰ deny tcp any any eq 4444 (3850 matches)
۴۷۰ deny tcp any any eq 5554 (369 matches)
۴۸۰ deny udp any any eq 1500 (173 matches)
۴۹۰ deny tcp any any eq 1919 (8152 matches)
۵۰۰ deny tcp any any eq 2967 (5250 matches)
۵۱۰ deny udp any any eq 2967 (101 matches)
۵۲۰ deny tcp any any eq 1425 (10084 matches)
۵۳۰ deny tcp any any eq 6667 (18607 matches)
۵۴۰ deny tcp any any eq 8943 (221 matches)
۵۵۰ deny tcp any any eq 4662 (3630 matches)
۵۶۰ deny tcp any any eq 1034 (2946 matches)
۵۷۰ deny tcp any any eq 81 (9123 matches)
۵۸۰ deny tcp any any eq 8181 (420 matches)
۵۹۰ deny tcp any any eq 2339 (6884 matches)
۶۰۰ deny tcp any any eq 31337 (331 matches)
۶۱۰ deny tcp any any eq 2745 (6134 matches)
۶۲۰ deny tcp any any eq 37 (39 matches)
۶۳۰ deny tcp any any eq 1500 (9704 matches)
۶۴۰ deny tcp any any eq 1501 (9367 matches)
۶۵۰ deny tcp any any eq 1502 (9473 matches)
۶۶۰ deny tcp any any eq 1503 (9126 matches)
۶۷۰ deny udp any any eq 1501 (160 matches)
۶۸۰ deny udp any any eq 1502 (258 matches)
۶۹۰ deny udp any any eq 1503 (168 matches)
۷۰۰ deny tcp any any eq 1214 (11340 matches)
۷۱۰ deny udp any any eq 65506 (326 matches)
۷۲۰ deny udp any any eq 3410 (158 matches)
۷۳۰ deny udp any any eq 3128 (148 matches)
۷۴۰ deny udp any any eq 3127 (202 matches)
۷۵۰ deny udp any any eq 8080 (207 matches)
۷۶۰ deny udp any any eq 1111 (408 matches)
۷۷۰ deny udp any any eq 8998 (9 matches)
۷۸۰ deny udp any any eq 27374 (51 matches)
۷۹۰ deny udp any any eq 1214 (107 matches)
۸۰۰ deny udp any any eq 9999 (36 matches)
۸۱۰ deny udp any any eq tftp
۸۲۰ deny udp any any eq 2745 (208 matches)
۸۳۰ deny tcp any any eq 1080 (10329 matches)
۸۵۰ deny tcp any any eq sunrpc (42 matches)
۸۶۰ deny tcp any any eq nntp (46 matches)
۸۷۰ deny tcp any any eq drip (4244 matches)
 
 
۸۸۰ deny tcp any any eq exec (1 match)
۸۹۰ deny udp any any eq rip (1 match)
۹۰۰ deny udp any any eq ntp (58094 matches)
۹۱۰ deny tcp any any eq 2283 (6850 matches)
۹۲۰ deny tcp any any eq 2535 (6262 matches)
۹۳۰ deny udp any any eq 1026 (1711 matches)
۹۴۰ permit ip any any (864701348 matches)
۹۵۰ permit icmp any any
 
 
 

 

 

لازم است یک ACL با سیاست خودتان و مثلا پورت های عمومی خطرآفرین تهیه و آنرا روی اینترفیس ورودی اعمال کنید.

 
 
conf t
int gig0/0
ip acce firewall in
ip acce firewall out
 
 
 

۲ – باز هم توصیه میشود دسترسی Telnet را با SSH جایگزین کنید.

۳ – آدرس های عمومی را در درگاه وروردی اینترنت جهت جلوگیری از Spoofing ببندید و یک نکته حرفه ای اینکه یک BGP Peering با شبکه team-cymru برقرار کنید و ورودی route ها را باز بگذارید این شرکت IP های BOGON را برای شما ارسال میکند و این لیست خود به خود آپدیت و جلوی route شما به این دسته از IP ها را میگیرد :

 
 
access-list 111 deny ip 127.0.0.0 0.255.255.255 any
access-list 111 deny ip 192.168.0.0 0.0.0.255 any
access-list 111 deny ip 172.16.0.0 0.0.255.255 any
access-list 111 deny ip 10.0.0.0 0.255.255.255 any
access-list 111 deny ip host 0.0.0.0 any
access-list 111 deny ip 224.0.0.0 31.255.255.255 any
access-list 111 deny icmp any any redirect
 
 
 

۴ – دسترسی SNMP را یا ببندید یا محدود کنید:

 
 
no snmp-server or >
snmp-server community SnMp@@!!123 RO 197
ip acce e 197
permit udptrusted host ipshostrouter ipeq snmp
deny ip any any
 
 
 

۵ – به جای enable password از enable secret استفاده کنید و پسورها را hash کنید:

 
 
service password-encryption
enable secret 5 f77a8a14ff273beddf3a6a3d3632158b/
username amirkhosro privilege 15 secret 5 $f77a8a14ff273beddf3a6a3d3632158b$.
 
 
 

 

این باعث میشود که دسترسی به پسورد شما حتی اگر کسی فایل کانفیگ روتر را هم داشته باشد غیر ممکن شود چون MD5مثلا یک الگریتم یک طرفه است !

۶ – سرویس بازنگاری پسورد را غیر فعل کنید: بدین ترتیب اگر کسی دسترسی فیزیکی هم به روتر پیدا کند نمیتواند پسور شما را ریکاور کند !

 

 
 
R1(config)#no service password-recovery
WARNING:
Executing this command will disable password recovery me
chanism.
Do not execute this command without another plan for
password recovery.
 
Are you sure you want to continue? [yes/no]:yes
 
 
 

۷ – سرویس هایی که بدرد شما نمیخورد را disable کنید:

شما باید بدونید از چه سرویس هایی استفاده می کنید و از کدوم ها استفاده نمی کنید. در زیر چنتا سرویس آورده شده است ولی ممکن است بعضی از سرویس های آورده شده در سناریوی شما کاربرد داشته باشد و ممکن است نداشته باشد پس دقت کنید.

 

 
 
Disable Echo, Chargen and discard
no service tcp-small-servers
no service udp-small-servers
 
Disable finger
no service finger
 
Disable the httpd interface
no ip http server
 
Disable ntp (if you are not using it)
ntp disable
 
Disable source routing
no ip source-route
 
Disable Proxy Arp
no ip proxy-arp روی تمامی اینترفیس ها
 
Disable ICMP redirects
interface gig0/0
no ip redirects روی تمامی اینترفیس ها
 
Disable Multicast route Caching
interface gig0/0 (your external interface)
no ip mroute-cache روی تمامی اینترفیس ها
 
Disable CDP
no cdp run
 
Disable direct broadcast (protect against Smurf attacks)
no ip directed-broadcast روی تمام اینترفیس ها
 
 
 

۸ – فقط IP های ست شده روی هر اینترفیس را مجاز کنید مثلا:

 

 
 
Core-Router#sh run int fastEthernet 0/1.300
Building configuration
 
Current configuration : 281 bytes
!
interface FastEthernet0/1.300
description esfehan
encapsulation dot1Q 300
ip address 217.218.1.1 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
end
Core-Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Core-Router(config)#ip acce e 130
Core-Router(config-ext-nacl)#per ip 217.218.1.0 0.0.0.7 an
Core-Router(config-ext-nacl)#per ip 217.218.1.0 0.0.0.7 any
Core-Router(config-ext-nacl)#per icmp any any
Core-Router(config-ext-nacl)#deny ip any any
Core-Router(config-ext-nacl)#exit
Core-Router(config)#int fas 0/1.300
Core-Router(config-subif)#ip acce 130 in
 
 
 

و صد البته روی اینترفیس خروجی فقط IP های شناخته شده شبکه خودتان را اجازه ترانزیت ترافیک بدهید

مثلا شما یک کلاس /۲۴ دارید ۲۱۷٫۲۱۸٫۱٫۰/۲۴:

 
 
Core-Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Core-Router(config)#ip acce e 131
Core-Router(config-ext-nacl)#per ip 217.218.1.0 0.0.0.255 any
Core-Router(config-ext-nacl)#per ip any 217.218.1.0 0.0.0.255
Core-Router(config-ext-nacl)#per icmp any any
Core-Router(config-ext-nacl)#deny ip any any
Core-Router(config-ext-nacl)#exit
Core-Router(config)#int gig 0/0 ( outside interface )
ip acce 131 in
ip acce 131 out
 
 
 

۹ – همه چیز را لاگ کنید:

 
 
logging trap debugging
logging 192.168.1.10
 
 
 

البته خیلی راه ها وجود دارد برای افزایش امنیت یک مسیریاب مثلا کنترل منابع در control-plane و … این نکات همانطور که در ابتدا اشاره شد حداقل کارهایی است که میبایست برای امنیت مسیریاب انجام دهید. این نکته هم بد نیست بدانید که اگر از گران ترین دستگاه هم استفاده کنید ولی خوب نکات امنیتی را رعایت نکرده باشید به راحتی از دستگاه شما عبور می کنند و البته هیچ وقت امنیت ۱۰۰ درصد نیست ولی میتوان خطرات را کاهش داد.

نظرات (0)

نظر ارسال شده‌ی جدیدی وجود ندارد

دیدگاه خود را بیان کنید

  1. ارسال دیدگاه بعنوان یک مهمان - ثبت نام کنید و یا وارد حساب خود شوید.
پیوست ها (0 / 3)
اشتراک‌گذاری موقعیت مکانی شما

خبرنامه سلام دیجی

در خبرنامه ایمیلی ما عضو شوید

به جمع همراهان ما بپیوندید و همواره بروز باشید

اطلاعات تماس

در صورت بروزمشکل می توانیدبه ایمیل زیرپیام ارسال کنیدinfo@hellodigi.ir

ساماندهی

logo-samandehi

درباره سلام دیجی

دیجی به کمک اساتید درهیچ زمانی از کمک کردن واموزش دادن به کاربران دست بر نمی دارد.از همه مهم تراینکه خود شما در ساخت دیجی می توانید نقش داشته باشیدباگذاشتن مقالات خودو آموزش به دیگران باعث یادگیری دوباره خود شویدوجایگاه خودرا درشته خودبدست آورید.لازم به ذکراست دیجی هیچ مالک واحد ومشخصی ندارد بلکه تمام کاربران او مالک و سازنده او هستند و هیچ گونه تبلیغاتی هم نمی پذیرد وفقط دانش می پذیرد

تمام حقوق سایت برای سلام دیجی و نويسندگان آن محفوظ می باشد