Search - SP Page Builder
Easy Profile - Search plugin
جستجو -مجموعه ها
جستجو - تماس ها
جستجو - محتوا
جستجو - خبرخوان ها
جستجو - وب لینک ها
جستجو - برچسب ها
cisco

کانفیگ GRE Tunnel در سیسکو

امتیاز کاربران

ستاره فعالستاره غیر فعالستاره غیر فعالستاره غیر فعالستاره غیر فعال
 

GRE Tunnel پروتکل لایه ۲ می باشد که یک Header به اسم GRE  به بسته ها می چسباند که کلیه اطلاعاتی که  در Tunnel در حال حرکت است را  درون خود نگهداری می کند   و توسط  GRE tunnel  محافظت می شود(توسط Header که GRE  می زند).

 

شبیه IPsec می ماند ولی به اندازه IPsec امنیت ندارد.معمولا روی GRE Tunnel  نیز IPsec اجرا می کنند.
Tunnel  دارای دو  سر فیزیکی می باشد که  مثل interface   ها IP  می گیرند و بسته های GRE  از Tunnel  ها عبور می کنند و زمانی که یک    GRE header به بسته اضافه می شود  باعث می شود حجم بسته ۲۴ Byte افزایش یابد و GRE  Tunnel با IOS های ۱۲,۴ به بالا کار می کند.GRE Tunnel   با تمام پروتکل های لایه ۳  IP,IP6,Apple tak  هم می تواند کار کند.
نکته مهمی که باید در مورد Tunnel  ها بدانید این است که Tunnel ها زمانی Up Up می شوند که دو  سر فیزیکی  interface  هایی که دارند بتوانند همدیگر را Ping  کنند.

 

 

کانفیگ GRE Tunnel

فرض کنید در شکل بالا R1  و R3  مخابرات می باشد و بین آنها  هر تعداد Router  می تواند وجود داشته باشد و R4 و R2  شعبات بانک ما هستند و پشت انها چندین Router & switch وجود دارد و می خواهیم از R2 با R4  ارتباط بر قرار کنیم برای این کار از Tunnel  استفاده می کنیم زیرا R1  و R3  به جز شبکه داخلی خودشان (مخابرات) با شبکه دیگر Neighbor  نمی شود.چراکه باعث می شود یک Routing Table بسار بزرگ برایشان ساخته شود.

اما اجازه می دهند که با Redistibute کردن Network های خارج از شبکه مخابرات  Network  های که به  Router مخابرات متصل هستند را در Routing Tablel  خود اضافه کند  تا با Default Rout  بتوان بسته ها را از طریق Router  مخابرات جابجا کرد.

مثلا R1 , R3  مخابرات هستند و config  زیر را مخابرات انجام داده است

R3:

R1:

R3(config)#router eigrp 100

R3(config-router)#no auto-summary

R3(config-router)#network 10.10.14.2 0.0.0.0

R3(config-router)# redistribute connected

R1(config)#router eigrp 100

R1(config-router)#no auto-summary

R1(config-router)#network 10.10.14.1 0.0.0.0

R1(config-router)# redistribute connected

Redistribute   کردن باعث میشود در اینجا تمام network هایی که به Router مرزی(R1,R3) به صورت connected  متصل هستند را به Routing table اضافه شوند.

 حال ما برای Router ها یک Default Route  تعریف می کنیم تا بسته هایی که از R2 می اید را به R4 برساند ازطریق R1 یعنی با استفاده از بستر مخابرات بسته هارا جابجا کند.

R2(config)#Ip route 10.10.0.0 255.255.0.0 10.10.12 .1

در اینجا ما یک   Static Route که  summary   رنج آن طرفه  R3  است را نوشته ایم اما می توان به صورت  Quad zero  هم Default route  را تعریف کنیم.

همین کار را در R4  هم انجام می دهیم تا بسته های که از R4 می اید را به R2 برسانیم از طریق R3 .

R4(config)#Ip route 10.10.0.0 255.255.0.0 10.10.34.1

 حال ارتباط R2 ,R4 با Tunnel  به روش زیر با هم بر قرار می کنیم
با این دستور ما وارد Tunnel  می شویم.

R2(config)#interface tunnel 10

 در اینجا عدد  ۱۰ شماره Tunnel  هست که می تواند بین ۰ تا ۲۱۴۷۴۸۳۶۴۷ باشد.

حال پس از مر حله بالا باید بگوییم که Tunnel  ما از کجا   به کجا می خواهد برود یعنی برایش Source  و Destination  تعریف کنیم.

R2(config-if)#tunnel Source s1/0
R2(config-if)#tunnel Destination 10.10.34.2

 و در اخر به Tunnel مثل interface  ها  IP  می دهیم

R2(config-if)#ip address 172.16.24.1 255.255.255.252

بعد همین کار را در R4 هم انجام می دهیم

R4(config)#interface tunnel 10

R4(config-if)#tunnel Source s1/0
R4(config-if)#tunnel Destination 10.10.12.2

R4(config-if)#ip address 172.16.24.2 255.255.255.252

بعد از این کار باید network  های پشت Router ها را (R1,R4) در یک Routing protocol تعریف  کنیم که از Router های پشت خود اطلاع داشته باشند . پس از تعریف network  ها با استفاده از network خود Tunnel  در Routing protocol  کاری می  کنیم که دو  Router R2,R4 با یک دیگر از طریق Tunnel و با استفاده از بستر مخابرات  بتوانند Neighbor شوند. این کار را با دستور زیر انجام می دهیم

R2(config)#router ei 100
R2(config-router)#network 2.2.2.2  ۰٫۰٫۰٫۰
R2(config-router)#network 172.16.25.1  ۰٫۰٫۰٫۰

بعد همین کار را در R4 هم انجام می دهیم

R4(config)#router ei 100
R4(config-router)#network 4.4.4.4  ۰٫۰٫۰٫۰
R4(config-router)#network 172.16.25.2  ۰٫۰٫۰٫۰

 حال ما می توانیم از R2  پشت R4  را ping  کنیم با استفاده از  Tunnel

 

معرفی فایروال PIX سیسکو

CDP و LLDP درسیسکو چیست

معرفی و پیکربندی EtherChannel بر روی سوئیچ های سیسکو

دستورالعمل بروز رسانی IOS روترهای سیسکو با استفاده از Internal Flash

اموزش acl در cisco

نظرات (0)

نظر ارسال شده‌ی جدیدی وجود ندارد

دیدگاه خود را بیان کنید

  1. ارسال دیدگاه بعنوان یک مهمان - ثبت نام کنید و یا وارد حساب خود شوید.
پیوست ها (0 / 3)
اشتراک‌گذاری موقعیت مکانی شما

خبرنامه سلام دیجی

در خبرنامه ایمیلی ما عضو شوید

به جمع همراهان ما بپیوندید و همواره بروز باشید

اطلاعات تماس

در صورت بروزمشکل می توانیدبه ایمیل زیرپیام ارسال کنیدinfo@hellodigi.ir

ساماندهی

logo-samandehi

درباره سلام دیجی

دیجی به کمک اساتید درهیچ زمانی از کمک کردن واموزش دادن به کاربران دست بر نمی دارد.از همه مهم تراینکه خود شما در ساخت دیجی می توانید نقش داشته باشیدباگذاشتن مقالات خودو آموزش به دیگران باعث یادگیری دوباره خود شویدوجایگاه خودرا درشته خودبدست آورید.لازم به ذکراست دیجی هیچ مالک واحد ومشخصی ندارد بلکه تمام کاربران او مالک و سازنده او هستند و هیچ گونه تبلیغاتی هم نمی پذیرد وفقط دانش می پذیرد

تمام حقوق سایت برای سلام دیجی و نويسندگان آن محفوظ می باشد