ثبت نام کن 

این بخش به صورت کاملاریگان است شما دراین بخش مقاله خود را درج می کنید از قسمت های ویژه سایت استفاده خواهید کرد و رتبه بندی می شوبد طبق فعالیت خود

مقاله را ثبت کن 

این قسمت برای ثبت مقاله شماست شما بااین کار مقاله خود را ثبت می کنید وباعث می شود دیگران هم ازمقاله شمااستفاده کندوباکمک دیگران مقالت راکامل کن

دیده و برتر شو

این بخش به شما کمک می کند تا شما معرفی شوید به کسانی که دنبال خدمات و کارهای شماهستند و شناخته شوید تا به کارایی  شما اطمینان کند وباشما طبق تخصص رفتارکند.

 

 

Hairpin NATچیست؟

در مورد Hairpin NAT مطلب خیلی کم هست و در دستگاه های مختلف تا جایی که من جستجو کردم نام متفاوتی دارد.برای توضیح این مطلب با یک سناریو شروع میکنم

فرض کنید یک شبکه داریم که در اون NAT انجام شده و بر روی روتر خودمون IP Valid داریم و با استفاده از اون IP سرور داخلیمون رو وارد اینترنت کردیم که از بیرون به اون دسترسی داشته

باشیم.حالا این سرور داخلی میتونه DVR یا NVR هم باشه.
خب تا اینجای کار همه چی به خوبی کار میکنه ولی اگه درست NAT رو انجام نداده باشیم یعنی کامل انجام نداده باشیم نمیتونیم از شبکه داخلی داخل مرورگر IP Validمون رو بزنیم مثلا صفحه وب سرورمون رو ببینیم و باید حتما IP INValid همون IP داخلی سرورمون رو بزنیم تا صفحه برامون باز بشه.
داخل انتقال تصویر خیلی زیاد پیش اومده که وقتی شخص با گوشیش به مودم ADSL یا روترش متصل هست و داخل نرم افزار تصویر DVR یا NVR میایم IP Valid رو میزنیم تا تصویر رو ببینه ولی نمیتونه ولی وقتی با اینترنت همراه یا خارج از شبکه داخلی خودش میزنیم به درستی کار میکنه.
خیلی از افراد به راحتی دوتا دستگاه داخل نرم افزار موبایل وارد میکنن و میگن هر زمان به وای فای خودتون متصل شدید از این یکی(که با IP داخلی هست) وصل بشید و وقتی از بیرون میخواید ببینید باید از این یکی دستگاه استفاده کنید تا تصاویر رو ببینید.

 

خب حالا Hairpin NAT چیه؟
این NAT یه نمونه ای از NAT هست که باعث میشه با IP INValid یعنی از داخل شبکه داخلیتون هم بتونید به IP Valid وصل بشید به سرورتون.مودم های 2015به بعد اکثرا این قابلیت رو دارند و خودشون این NAT رو وارد میکنن که اگه زمانی بخواد از شبکه داخلی به IP Valid متصل بشه مسئله ای نداشته باشه و برای مودم هایی که این قابلیت رو ندارند هم راهکار وجود داره که از این بحث خارجه.مطلب مورد بحث ما داخل میکروتیک چجوری پیاده سازی کنیم تا از این قابلیت استفاده کنیم؟

در ابتدا شما با استفاده از یک dst-nat سرور خودمون رو از بیرون قابل دسترسی میکنیم به روش زیر:

/ip firewall nat
add chain=dstnat dst-address=1.1.1.1 protocol=tcp dst-port=80 action=dst-nat to-address=192.168.1.2
add chain=srcnat out-interface=WAN action=masquerade

با این کار سرور ما با IP 192.168.1.2 از بیرون قابل دسترسی میشه.
ولی از شبکه داخلی باید ما حتما 192.168.1.2رو وارد کنیم تا بتونیم به سرور متصل بشیم و با وارد کردن1.1.1.1نمیشه به سرور دسترسی داشت.
حالا برای دسترسی از داخل شبکه به اون سرور از طریق 1.1.1.1 باید رول زیر رو وارد روترتون کنید.

/ip firewall nat
add chain=srcnat src-address=192.168.1.0/24 dst-address=192.168.1.2 protocol=tcp dst-port=80 out-interface=LAN action=masquerade


 

بهبود موبایلیتی کاربران و اشنای باCapsman

دانلود MikroTik os 5.26

آموزش نصب میکروتیک در VMware Workstation

Tunnel GRE در میکروتیک

آموزش نحوه لایسنس کردن میکروتیک

 

 

نوشتن دیدگاه


تصویر امنیتی
تصویر امنیتی جدید

فرم تماس

هدف ما ارائه بهترین خدمات به شما می باشد . مشتاقانه منتظر نظرات و انتقادات شما هستیم .

اطلاعات تماس

آدرس:
ایران،تهران، سعادت اباد
تلفن:55101946-021

logo-samandehi
  
  توضیحات مختصر:
 
 سایت digi درتاریخ1395/6/6 فعالیت خود را در زمینه توسعه و ارائه خدمات اموزشی درفضای مجازی به طور رسمی آغاز نمود.digi درایران و کشور های دیگر طرفداران زیادی،چه درمیان کاربران حرفه ای وچه درمیان کاربران عادی ومعمولی در این زمان کوتاه کسب کرده است .hellodigi با دراختیارداشتن 20سرورپشتیبان همیشه بروزمی باشدودرهیچ زمانی از کمک کردن و اموزش دادن  کاربران خوددست بر نمی دارد.از همه مهم تراینکه خود شما در ساخت سایت hellodigi می توانید نقش داشته باشید باگذاشتن مقالات خودو آموزش به دیگران باعث یادگیری دوباره خود شوید وجایگاه خود را درشته خود بدست آورید.

 

با ما در تماس باشید